PHC Web App Outage
Incident Report for US - LifeOmic
Resolved
The outage has been resolved.
Posted over 1 year ago. Jul 03, 2018 - 16:55 EDT
Identified
The Precision Health Cloud web app is currently down. We are working to resolve the issue.
Posted over 1 year ago. Jul 03, 2018 - 16:49 EDT
This incident affected: Web Apps.