PHC New User sign up
Incident Report for US - LifeOmic
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 29, 2018 - 16:26 EST
Update
We are continuing to work on a fix for this issue.
Posted 8 months ago. Nov 29, 2018 - 15:51 EST
Identified
Users signing up to use the Precision Health Cloud are experiencing unexpected behavior. We have identified the issue and will be releasing a fix soon. Existing users with an active account are unaffected at this time.
Posted 8 months ago. Nov 29, 2018 - 15:01 EST
This incident affected: Web Apps.